Samsung YP-S3 e Ubuntu, problema risolto

Ho da qualche giorno comprato un lettore mp3/mp4/jpg Samsung YP-S3, davvero un bel giocattolino…se non fosse che Ubuntu non me l’abbia riconosciuto subito. Senza farmi prendere dal panico, ho fatto qualche piccola ricerca, ma sembra che nessuno sia riuscito a risolvere il problema…fino a quando non sono riuscito a farlo andare da solo

I passi da seguire sono i seguenti:

  1. Scaricare da qui la libreria libmtp-0.3.1;
  2. Installarla dai sorgenti come un qualsiasi programma (per le istruzioni, click qui);
  3. Al termine dell’installazione, copiare la libreria nella cartella /etc/udev/ con il seguente comando: sudo cp libmtp.rules /etc/udev/rules.d;
  4. Riavviare il servizio udev, per far si che riconosca le modifiche appena apportate, con il comando sudo /etc/init.d/udev restart

A questo punto si può controllare che il lettore sia rilevato dal sistema tramite il comando sudo mtp-detect (non vi riporto l’output, è molto lungo ed eventualmente lo trovate su questo mio post scritto sul forum di Ubuntu-it): il lettore dovrebbe accendersi istantaneamente, e sarà quindi rilevato dal software (qualsiasi software dovrebbe andar bene, personalmente uso Gnomad2, installato con il comando sudo apt-get install gnomad2)

Buoni mp3 a tutti

[techtags: Samsung YP-S3, Ubuntu, libmtp, gnomad2]

 

13 risposte a “Samsung YP-S3 e Ubuntu, problema risolto”

  1. rob, a dire il vero non l’ho provato, ma sul forum di ubuntu-it dicono che senza quella libreria non funzioni lo stesso…ora è tardi per provare (anche se potrei farlo sul laptop della mia ragazza..ti fò sapere!)
    unico problema rimasto: non è possibile fare l’upload di foto e video, solo musica…

  2. Il problema è che probabilmente hardy avrà una versione vecchia della libmtp, magari con intrepid non avrai bisogno di compilarla da sorgente. Comunque, take a look. 😉

  3. ho installato tutto senza problemi,ho svolto i passaggi successivi senza problemi, ho riavviato udev, ma non me lo riconosce ancora….il terminale quando gli do il comando mtp-detect da root mi dice che il comando non esiste…. 😕 potreste spiegarmi dov’è l’errore per favore?

  4. ciao mrc, hai seguito tutto passo-passo? purtroppo non ho qui il lettore, di conseguenza non posso fare i test (che tra l’altro sarebbero utili, visto che parto da un’installazione – pulita – di Karmic Koala).
    Eventualmente, hai provato anche la “soluzione” Rhythmbox suggerita da robi?

  5. si, ho eseguito tutto passo passo, ma non funzionava lo stesso, stasera girando nel gestore pacchetti synaptic ho trovato il pacchetto mtp-tools, e dopo averlo installato ho provato a collegare il lettore e finalmente lo riconosce! grazie x la guida, solo è necessario installare questo piccolo pacchetto necessario per il funzionamento, almeno x la mia distro.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *